Bug 537 - cyberdemon and other items spawn randomly in ctf
: cyberdemon and other items spawn randomly in ctf
Status: RESOLVED FIXED
Product: Odamex
Classification: Unclassified
Component: Server
: (old) 0.4
: All All
: P2 critical
Assigned To: Russell Rice
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 19:53 UTC by Denis Lukianov
Modified: 2009-12-30 17:07 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Lukianov 2009-04-24 19:53:59 UTC
(01:32:48) denis: how does one reproduce the cyberdemon ctf bug (and why is it not in bugzilla)?
(01:45:24) Ralphis: i think a lot of those tests occured during the time the bug tracker had been down
(01:45:50) Ralphis: and how to reproduce it? play a game with a bunch of connections
(01:46:07) denis: cyberdemon appears serverside?
(01:47:06) Ralphis: more than cyberdemons
(01:47:14) Ralphis: but cyberdemon is the most consistent and always spawns at 0,0
(01:47:19) Ralphis: other items appear at other coordinates
(01:50:36) denis: interesting, is it difficult to reproduce?
(01:52:47) denis: i imagine it's not difficult to breakpoint it once the thing happens
(01:53:35) denis: any particular wad/map?
(01:54:23) Ralphis: we had it happen on the zdctf boom conversion, 2cctg-2 or something other
(01:54:44) Ralphis: if you get a game going you can reproduce it easily, it's going to happen eventually
(01:55:10) Ralphis: ghostlydeath ran a debugger when it happened but either he didn't find anything or, what I think might be more likely, didn't actually know what he was looking for
(01:55:24) Ralphis: cybs ALWAYS spawn at 0,0 though, other things spawn elsewhere
(01:55:33) Ralphis: sometimes only one cyb will spawn, sometimes about 500 will
(01:55:38) Ralphis: not at the same time
(01:55:44) Ralphis: and they actually "teleport" in, with the teleport sprite and all
Comment 1 Denis Lukianov 2009-04-24 19:56:03 UTC
(02:00:50) Ralphis: there were a few conditions we used which seemed to make it occur more frequently but who can be sure if they really did make it occur more frequently
(02:00:54) Ralphis: mostly ctf_manualreturn 1
Comment 2 Ralph Vickers 2009-04-25 16:45:24 UTC
also skill 5
Comment 3 Russell Rice 2009-05-08 00:15:01 UTC
This is possibly related

Odactf1.wad map04 c/s, by the 2 boxes in the middle of the map, if you pick up a flag and score, sometimes you will get a dead body on a stake appear at 0,0 (which is next to one of the boxes)

it was on the coffeenet.org server I witnessed this, and it only happens if you score with the flag it seems
Comment 4 Russell Rice 2009-05-08 00:21:40 UTC
(In reply to comment #3)
>
> and it only happens if you score with the flag it seems
> 

Scrub that, all you have to do is pick up the flag and watch out the window, but scoring doesn't make a difference

It also spawns like an item, with a flash and the item respawn sound
Comment 5 Denis Lukianov 2009-05-08 00:55:54 UTC
can't reproduce this locally

client/server

Odactf1.wad map04
gametype 3
skill 5
ctf_manualreturn 1

tried as blue and red player
Comment 6 Denis Lukianov 2009-05-08 01:40:17 UTC
CTF_CarryFlag and CTF_MoveFlags do look suspect, but that would only create clientside monsters
Comment 7 Russell Rice 2009-05-08 08:05:32 UTC
try: itemsrespawn 1
Comment 8 Denis Lukianov 2009-05-13 14:08:35 UTC
(In reply to comment #7)
> try: itemsrespawn 1
> 

nope
Comment 9 Russell Rice 2009-05-13 17:37:14 UTC
I made a vid a little while ago about it which shows the issue:

http://russell.mancubus.net/mov/bug%20537/
Comment 10 HeX_Vulture 2009-05-15 09:34:16 UTC
(In reply to comment #3)
> This is possibly related
> 
> Odactf1.wad map04 c/s, by the 2 boxes in the middle of the map, if you pick up
> a flag and score, sometimes you will get a dead body on a stake appear at 0,0
> (which is next to one of the boxes)
> 
> it was on the coffeenet.org server I witnessed this, and it only happens if you
> score with the flag it seems
> 

I was able to successfully reproduce this thanks to this description and the video. Just letting you guys know its not specific to Russell's system. Debian 5.01 here in case that info is needed.

Feel free to use my server to reproduce this bug, Ralph has the rcon but if you guys need any additional help just ask.
Comment 11 Russell Rice 2009-06-19 13:02:48 UTC
Nes committed a possible fix (it fixes the corpse-on-pike spawn), please test r1284
Comment 12 Russell Rice 2009-11-04 21:31:17 UTC
This bug has gone stale, I've tested and it works, if it occurs for anyone please respond in the next 10 days or I'm closing this
Comment 13 Mike Lightner 2009-12-30 17:07:19 UTC
Marking fixed.  If it comes up again create a new bug.