Bug Tracker – Full Text Bug Listing

Bug 293

Summary: Ghost Monsters in Coop
Product: Odamex Reporter: Dr. Zin <griffiniic>
Component: ClientAssignee: Odamex Bug Reporter <odamex-bug-reporter>
Status: ASSIGNED ---    
Severity: major CC: crossie, mdvulture, raijinsc, Ralphis, wad_beta
Priority: P2    
Version: (old) 0.x Alpha   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 424, 32, 620    

Description Dr. Zin 2007-01-21 12:56:25 UTC
There seem to be sporadic instances of ghost monsters in coop, except they occur in maps that do not contain archviles. Suspect monsters are spawned as ghosts.
Comment 1 Ralph Vickers 2010-01-15 06:36:42 UTC
Still occurs as of r1431. This can work one of two ways, both caused by client/server disagreements:

1) A monster is still alive client side but dead server side. This causes a useless monster to run around aimlessly on your screen, never attacking or doing anything. You cannot kill it as it is already dead server side.

2) A monster is dead client side but still alive server side. This causes an invisible monster to be able to attack you because, though you see nothing on your screen, the monster is attacking your player on the server. I've found this to be much more rare than the opposite desync above.

Have not found a reliable way to reproduce other than playing a lot of coop as of r1431.
Comment 2 Luiz Henrique 2010-12-17 21:21:04 UTC
This bug and old but I'll leave my opinion, I see I was playing an online game with 4 players each, now go straight to the point in a certain time a player says he'll shoot at the enemy but he did not die after a few shots and he does not feel but the shot and the bullet passed through him hitting the wall, we all saw the show and nobody could even killed it with punch, and he shot at us and we did not feel anything, and one more thing he did not spend inside of us but we were spending on in giving such a feeling to be lagging!

Much fun we see the monster trying to kill us without getting anything! :)
Comment 3 crossie 2011-10-05 02:53:24 UTC
*** Bug 755 has been marked as a duplicate of this bug. ***
Comment 4 Mike Lightner 2014-03-30 16:21:06 UTC
This is ongoing...
Comment 5 Soul Sucka 2019-01-27 00:34:48 UTC
Can confirm this still happens on version 0.8.0.