Bug Tracker – Bug 1012

Inaccurate prediction leads to fake weapon pickups

Last modified: 2019-01-06 03:04:07 CST
Bug 1012 - Inaccurate prediction leads to fake weapon pickups
Summary: Inaccurate prediction leads to fake weapon pickups
Status: RESOLVED DUPLICATE of bug 1099
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.6.x
Hardware: All All
: P1 major
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks:
 
Reported: 2013-09-30 02:31 CDT by Ivan T
Modified: 2019-01-06 03:04 CST (History)
1 user (show)

See Also:

Attachments

Related Instance (579.49 KB, application/octet-stream)
2013-09-30 03:25 CDT, Ru5tK1ng
Details
Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan T 2013-09-30 02:31:39 CDT
If you skim by a weapon (not sure if this bug also extends to items), the client will inform you that you have picked up the item (sound and message), but on the server you will not actually have the weapon. This is a widespread issue amongst many players.
Comment 1 Ru5tK1ng 2013-09-30 03:25:51 CDT
Created attachment 446 [details]
Related Instance

If you jump to 1:14 in the demo, you will see me grabbing the rocket launcher and attempt to fire it only to have no rockets discharge. This easily happens many times during an actual game on this map.
Comment 2 Ralph Vickers 2019-01-06 03:04:07 CST
Duplicate.

*** This bug has been marked as a duplicate of bug 1099 ***