Bug Tracker – Bug 1013

FPS drops

Last modified: 2019-01-06 03:07:08 UTC
Bug 1013 - FPS drops
Summary: FPS drops
Status: RESOLVED FIXED
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.6.x
Hardware: All All
: P1 normal
Assignee: Odamex Bug Reporter
URL:
: 999 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-30 02:33 UTC by Ivan T
Modified: 2019-01-06 03:07 UTC (History)
3 users (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan T 2013-09-30 02:33:49 UTC
When you alt-tab, or when a new round start (of CTF for example), there is a random chance that the game's FPS will be cut sharply. I'm not sure by how much, but me and many other players can confirm that this does happen with 35fps setting, not sure if it happens with higher FPS settings.
Comment 1 Dr. Sean 2013-09-30 02:36:30 UTC
A little additional background on that bug:

The frame rate of the renderer does not in fact drop, as the on-screen FPS widget indicates the renderer is still performing at 35.0fps. However, it appears to me that the game simulation is not running at even intervals. This means that during some intervals, the game simulation will not run at all and then the next interval, two frames of game simulation will run.
Comment 2 Dr. Sean 2013-09-30 02:40:11 UTC
*** Bug 999 has been marked as a duplicate of this bug. ***
Comment 3 capo 2015-01-10 14:57:42 UTC
This bug seems be gone, dont noticed it for long time.
Comment 4 Ralph Vickers 2019-01-06 03:07:08 UTC
Marking this closed. No follow up for a long time and haven't heard anything about this for ages. SDL2 also changes the way fullscreen and alt+tabbing works, which may have helped.