Bug Tracker – Bug 103

Reimplement intermission screen

Last modified: 2010-01-15 05:31:41 UTC
Bug 103 - Reimplement intermission screen
Summary: Reimplement intermission screen
Status: RESOLVED FIXED
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.0.1
Hardware: Other All
: P2 normal
Assignee: Nes
URL:
Depends on:
Blocks: 3 122
  Show dependency tree
 
Reported: 2006-02-11 22:46 UTC by Dylan McIntosh
Modified: 2010-01-15 05:31 UTC (History)
2 users (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Dylan McIntosh 2006-02-11 22:46:44 UTC
We want to have the origonal intermission screen,
Comment 1 Denis Lukianov 2006-03-12 14:39:44 UTC
r1082 re-enables wi_stuff intermission screens
Comment 2 Mike Lightner 2006-03-12 19:04:25 UTC
It's better.  It shows the small little scoreboard, we may want to change/spruce that up a bit.  It also will melt to the last frame THEN switch to the intermission screen.  It should most likely wipe right to the intermission screen.
Comment 3 Denis Lukianov 2006-03-20 17:18:34 UTC
there are also problems with timing for finale screens, everything is still timed TICRATE*10, or whatever, so finale text doesn't read all the way through
Comment 4 Denis Lukianov 2006-03-20 23:38:53 UTC
(In reply to comment #2)
> It's better.  It shows the small little scoreboard, we may want to
> change/spruce that up a bit.  It also will melt to the last frame THEN switch
> to the intermission screen.  It should most likely wipe right to the
> intermission screen.

This only happens for wad changes via addmap now
Comment 5 Denis Lukianov 2006-04-06 18:38:45 UTC
from comment 30 in bug 32:

> - after d2m7 there is an intermission screen telling the story, i'd like to see
> this back.
> 
.. actually, it's _before_ map07.
Comment 6 Dean Joseph 2006-10-07 16:22:35 UTC
r1717 utilizes the HUD scoreboard for intermission on all gametypes. There is some leftover variables that need to be removed (I'll do this later today), but it should be working fine.

However, there is a bug where the palette 'fade' (damaged, picked up item etc) doesn't get removed if it exists just before exiting the level. I might look into this and see what I can do.
Comment 7 Denis Lukianov 2006-11-07 20:21:21 UTC
(In reply to comment #6)
> r1717 utilizes the HUD scoreboard for intermission on all gametypes. There is
> some leftover variables that need to be removed (I'll do this later today), but
> it should be working fine.

No. Please read the above comments. Coop should not do this. Bring back the original code or make it optional.
Comment 8 Denis Lukianov 2006-11-07 20:22:39 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > r1717 utilizes the HUD scoreboard for intermission on all gametypes. There is
> > some leftover variables that need to be removed (I'll do this later today), but
> > it should be working fine.
> 
> No. Please read the above comments. Coop should not do this. Bring back the
> original code or make it optional.

Specifically, I refer to the storyline code between map06 and map07 (but some people might like the old score count too).

Comment 9 Alexander Mayfield 2006-11-07 21:52:21 UTC
Supposedly this was implimemented at one point, but as of r1966 the intermission screen doesn't clear, however, it seems like the server allows the extra time to allow the story to be told.

Please fix
Comment 10 Alexander Mayfield 2007-03-09 11:39:11 UTC
My previous explination was a little confusing, and I tried to replicate it, and this is what I did...

* I edited my odasrv.cfg file to be cooperative and have map06 and map07 in a rotation.
* I then loaded the server (which didn't load the config for some reason), and exec odasrv.cfg and map map06-ed it.
* I then connected with the client and beat map06.
* The intermission screen lasted a very long time (the bug?), and when it finally cleared I was in map06 again (not a bug, just a side effect of the configuration).
* I beat map06 agan and this time the intermission was fast, and I ended up in map07 immediatly.

The bug is that sometimes intermissions last a long time.  I theorize it has something to do with the story text, but I'm not sure.
Comment 11 Alexander Mayfield 2007-03-09 11:40:41 UTC
My previous explination was a little confusing, and I tried to replicate it, and this is what I did...

* I edited my odasrv.cfg file to be cooperative and have map06 and map07 in a rotation.
* I then loaded the server (which didn't load the config for some reason), and exec odasrv.cfg and map map06-ed it.
* I then connected with the client and beat map06.
* The intermission screen lasted a very long time (the bug?), and when it finally cleared I was in map06 again (not a bug, just a side effect of the configuration).
* I beat map06 agan and this time the intermission was fast, and I ended up in map07 immediatly.

The bug is that sometimes intermissions last a long time.  I theorize it has something to do with the story text, but I'm not sure.
Comment 12 Mike Lightner 2008-07-27 12:52:24 UTC
What's the latest with this bug?  Reassigning to Nes.
Comment 13 Ralph Vickers 2010-01-15 05:31:41 UTC
Intermission screens have been in forever. Marking fixed as of r1431