Bug Tracker – Bug 1068

Enhance coop Counter-"telefragging"

Last modified: 2016-11-17 15:13:28 UTC
Bug 1068 - Enhance coop Counter-"telefragging"
Summary: Enhance coop Counter-"telefragging"
Status: RESOLVED WONTFIX
Alias: None
Product: Odamex
Classification: Unclassified
Component: Server & Client (show other bugs)
Version: 0.7.x (Old)
Hardware: All All
: P1 enhancement
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks:
 
Reported: 2014-04-11 17:52 UTC by Maëllig Desmottes
Modified: 2016-11-17 15:13 UTC (History)
1 user (show)

See Also:

Attachments

Patch for enhancing telefragging issues (1.87 KB, application/octet-stream)
2014-04-11 17:52 UTC, Maëllig Desmottes
Details
Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Maëllig Desmottes 2014-04-11 17:52:37 UTC
Created attachment 491 [details]
Patch for enhancing telefragging issues

Amateur Fragger's Idea gives us the possibility to unblock players, when they are overlapping together (i.e when telefragging).

However, in cooperation, telefragging can still happen, either in spawns (if 4+ players starting together a new level), or when sv_friendlyfire is set to 0.

A better way, not to make people "rage" when joining a new map with stuff and being instantly telefragged, is to enable telefragging with friendlyfire set to 1, or in non-cooperative gamemodes.
Also, if 2 players are stuck because of teleporting, unstuck them by making them able to move.

Differences associated with latest rev.
Comment 1 Ralph Vickers 2016-11-15 01:05:29 UTC
Thank you for the patch Choww. After some discussion (which is mentioned by Heks in comment 3 of bug 629), we determined that the best way to do this is probably to simply protect players from telefrag with an unblock function. The reason for this is because, when preventing spawns or teleports, maps can become broken (one way teleport over a cliff for instance) or certain players can prevent the progress of others by simply standing on a destination. For this reason, we are unlikely to implement this in such a form and will mark this "won't fix".
Comment 2 Maëllig Desmottes 2016-11-17 15:13:28 UTC
Actually, I noticed I was unclear in the description of the ticket.

The main problem (as I remember) was that in cooperative, you could telefrag your friends when the teamdamage and unblockplayers were set to 0. 

The problem is: why would you kill someone if you tried to prevent that fate from happening? in PvP modes, it's not a problem, but in PvE, it's another story, given you may also lose your equipment.

So, the solution I did in the patch was to temporarly unblock players that were going to move through a teleporter, disabling the telefrag. So that they could pass through each other until the two hitboxes stop touching each other.

Hoping this may understand a little more the enhancement I was sending.