Bug Tracker – Bug 1135

Custom colormap is ignored in 32-bit video mode

Last modified: 2016-09-16 18:45:59 UTC
Bug 1135 - Custom colormap is ignored in 32-bit video mode
Summary: Custom colormap is ignored in 32-bit video mode
Status: ASSIGNED
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: 0.7.x (Old)
Hardware: All All
: P1 trivial
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks:
 
Reported: 2015-01-18 07:14 UTC by Mike Lightner
Modified: 2016-09-16 18:45 UTC (History)
0 users

See Also:

Attachments

A simple wad containing custom palette and colormap lumps (19.04 KB, application/x-doom)
2015-01-18 07:14 UTC, Mike Lightner
Details
Using wad in 8-bit video mode (113.20 KB, image/png)
2015-01-18 07:15 UTC, Mike Lightner
Details
Using wad in 32-bit video mode (304.52 KB, image/png)
2015-01-18 07:16 UTC, Mike Lightner
Details
Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Lightner 2015-01-18 07:14:15 UTC
Created attachment 518 [details]
A simple wad containing custom palette and colormap lumps

This isn't a huge issue, but it appears the colormap is not being taken into consideration in 32-bit video mode.  I am not sure if this is a known issue or an oversight, but certainly there is some way to use the data there to clamp the ranges for brightness etc?

I have attached a simple wad created by Linguica that contains a palette and a colormap.  You can see the difference if you change from 8 to 32 and back.
Comment 1 Mike Lightner 2015-01-18 07:15:14 UTC
Created attachment 519 [details]
Using wad in 8-bit video mode
Comment 2 Mike Lightner 2015-01-18 07:16:28 UTC
Created attachment 520 [details]
Using wad in 32-bit video mode
Comment 3 Mike Lightner 2016-09-16 18:45:59 UTC
Bug is marked assigned