Bug Tracker – Bug 1149

Build 5414 x86-64 no music or sound when midi output is sdl_mixer

Last modified: 2016-09-16 00:09:41 CDT
Bug 1149 - (ARRAY(0x4b962e8)) Build 5414 x86-64 no music or sound when midi output is sdl_mixer
(ARRAY(0x4b962e8))
Build 5414 x86-64 no music or sound when midi output is sdl_mixer
Status: NEW
Product: Odamex
Classification: Unclassified
Component: Client
0.7.x
x86 (Windows, Linux, etc) Windows 8
: P1 normal
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2015-07-09 21:31:37 CDT by Absolute Zero
Modified: 2016-09-16 00:09 CDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Absolute Zero 2015-07-09 21:31:37 CDT
Game stops playing sounds and music when midi output is sdl_mixer, both are activated again only when midi output is portmidi.

portmidi -> sdl_mixer = no music or sounds
portmidi -> no music = no music, but sounds are played
sdl_mixer -> no music = no music or sounds
sdl_mixer -> portmidi = music and sounds works
no music -> portmidi = music and sounds works
no music -> sdl_mixer = no music or sounds

Windows 8.1, 64 bits.
Comment 1 HeX_Vulture 2016-09-07 13:36:12 CDT
Does this still occur as of latest SVN?
Comment 2 Absolute Zero 2016-09-14 07:51:40 CDT
(In reply to HeX_Vulture from comment #1)
> Does this still occur as of latest SVN?

I just compiled a binary under Debian Jessie 8.5 AMD64, revision number 5471, and it seems fixed. Can't tell if it is fixed on Windows 8.1 because I don't use it anymore.
Comment 3 HeX_Vulture 2016-09-16 00:09:41 CDT
Thanks, but I think we need to get verification from Windows 8.1 64-bit users just to be safe. I am using Windows 10 and do not have this issue.

Zero you might want to get the development libraries fro SDL2 and SDL2_Mixer and compile the SDL2 branch. We are currently testing it.