Bug Tracker – Bug 1186

Odamex captures mouse5 as mouse2

Last modified: 2019-07-30 15:16:07 CDT
Bug 1186 - Odamex captures mouse5 as mouse2
Summary: Odamex captures mouse5 as mouse2
Status: RESOLVED WORKSFORME
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: 0.7.x (Old)
Hardware: x86 (Windows, Linux, etc) All
: P1 normal
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks:
 
Reported: 2016-09-17 12:10 CDT by Anthony Weed
Modified: 2019-07-30 15:16 CDT (History)
4 users (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Weed 2016-09-17 12:10:59 CDT
If strafe is bound to mouse2, and mouse5 is pushed, sometimes it will capture as mouse2.  This occurs in Windows 10 64KB with a Zowie FK1.  Version .7x r5470 SDL2
Comment 1 HeX_Vulture 2016-09-17 18:30:46 CDT
I do not have this issue with a generic Liger plug & play mouse with Windows 10 64-bit
Comment 2 capo 2016-10-01 18:58:23 CDT
I have same windows and "same" mouse. I got zowie ec2-a model. And i tested it and have not problems at all. It can sounds like cliche but buy some better model like EC or ZA. FK were the worst zowie mouses ever and got a lot problems with lagging buttons, bad sensors etc.
Comment 3 HeX_Vulture 2018-12-24 09:19:38 CST
Tony are you still having this issue?
Comment 4 HeX_Vulture 2018-12-24 09:22:29 CST
Tony are you still having this issue? Please test with the latest build of Odamex here:

https://ci.appveyor.com/project/odamex/odamex/branch/master/artifacts

It uses SDL2
Comment 5 Ralph Vickers 2018-12-24 18:01:29 CST
I tested with a hirality and mouse4/5 work. Tested in sdl2 builds
Comment 6 Maëllig Desmottes 2019-01-01 12:54:26 CST
So is this problem due to the mouse itself, or a SDL/SDL2 problem ?

Because I don't even have the problem on my different mouses (Logitech MX518 / G400 / G402 , Razer Deathadder / Copperhead). So I'm assuming the problem is the mouse itself (as capo said).
Comment 7 HeX_Vulture 2019-07-30 15:16:07 CDT
marking resolved because we can't reproduce