Bug Tracker – Bug 1209

mouse_driver not working

Last modified: 2019-01-06 00:01:31 CST
Bug 1209 - mouse_driver not working
Summary: mouse_driver not working
Status: RESOLVED FIXED
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: 0.7.x (Old)
Hardware: x86 (Windows, Linux, etc) Windows (Any)
: P1 normal
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks: 1231
  Show dependency tree
 
Reported: 2016-11-12 08:37 CST by capo
Modified: 2019-01-06 00:01 CST (History)
3 users (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description capo 2016-11-12 08:37:08 CST
Ive tested latest build (5522) on Windows 10 and raw input is not working with this revision. When i switch to sdl mouse its working again.
Comment 1 HeX_Vulture 2016-11-12 11:41:19 CST
This is because SDL2 uses raw input by default, so the code for 0.7.0's raw input has been removed.
Comment 2 capo 2016-11-12 13:55:48 CST
Oh yeah i thought it has something to do with SDL2. So what is the future of the mouse inputs? Adding also directinput? I probably could not bother with directinput, its bad, nobody use it. Raw is way better anyway. I think raw and traditional windows mouse input could be the best probably. Like there is big change odamex still/will play users with old mouses and shit. So raw could cause problems for them i guess...
Comment 3 Ralph Vickers 2016-11-12 19:18:06 CST
mouse_driver is going to be removed for the new release so this will be marked fix once that is committed
Comment 4 Dr. Sean 2019-01-05 20:20:20 CST
I merged a PR to remove "mouse_driver" CVAR and raw input code. SDL 2.0 provides raw mouse input already so this is no longer needed.
Comment 5 Ralph Vickers 2019-01-06 00:01:31 CST
Confirmed. Marking fixed. Thank you Sean!