Bug Tracker – Bug 1210

Big fps drops when red screen

Last modified: 2016-11-27 12:24:07 CST
Bug 1210 - (ARRAY(0x65037d8)) Big fps drops when red screen
(ARRAY(0x65037d8))
Big fps drops when red screen
Status: NEW
Product: Odamex
Classification: Unclassified
Component: Client
0.7.x
x86 (Windows, Linux, etc) All
: P1 normal
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2016-11-13 08:18:41 CST by capo
Modified: 2016-11-27 12:24 CST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description capo 2016-11-13 08:18:41 CST
Tested with newest revision and SDL2. Basically when you got red screen by taking berserk or when you got hit your fps massive drops by like 50% probably. It happens only in 32bit renderer. It wont happens when you have red pain intesity off.
Comment 1 Ralph Vickers 2016-11-13 17:26:28 CST
Please provide more information in your bug reports. What are your system specs, what resolution are you running at, what is r_optimize set to?

I cannot reproduce this bug at significant levels under the following conditions:
Specs: Win 7, AMD 4100+, 16gb ram
Oda settings: 1920x1080, 32-bit color
Comment 2 capo 2016-11-14 01:17:45 CST
Spec: i5 6500, gtx 980, 16 gb ram, Win 10 64 bit

I play with 720p res and unlimited FPS and 32 color bit. Ny r_optimize is to "none". I know when i tried this command. It just told me "available optins are none and detect". When i try "detect", it just auto set to none with "r_optimize set to none based on availability". The command is broken for me now. But in stable 0.7 its "sse2", Btw i tried also stable 0.7 version and bug is also there. Ofc i never noticed , since i have red pain intensity disabled.
Comment 3 capo 2016-11-27 11:36:04 CST
I used another client with sdl2 and stuff and i can now set to sse2 which fix the problem...
Comment 4 Samuel VISCAPI 2016-11-27 12:24:07 CST
Hi all,

Looks similar to bug #1170 (on ARM platform, no optimizations yet).

Cheers, Sam