Bug Tracker – Bug 1239

Player sometimes unable to cross open doors if opened at certain angles

Last modified: 2019-01-05 09:31:41 UTC
Bug 1239 - Player sometimes unable to cross open doors if opened at certain angles
Summary: Player sometimes unable to cross open doors if opened at certain angles
Status: RESOLVED DUPLICATE of bug 1238
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: 0.7.x (Old)
Hardware: x86 (Windows, Linux, etc) Windows 2000/XP/Vista/7
: P5 normal
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks:
 
Reported: 2019-01-05 03:14 UTC by Soul Sucka
Modified: 2019-01-05 09:31 UTC (History)
1 user (show)

See Also:

Attachments

SSL2 demo showcasing the bug (527.67 KB, application/octet-stream)
2019-01-05 03:14 UTC, Soul Sucka
Details
Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Soul Sucka 2019-01-05 03:14:10 UTC
Created attachment 564 [details]
SSL2 demo showcasing the bug

When the player is running (or straferunning), if they bump into a door and open it at certain angles (without letting go of the running inputs), they remain frozen in place even after the door is already open for them to cross. When that happens, the player is also shown to be in a running animation in others' POV, in spite of staying completely still in practice. This is fixed by letting go of the running inputs and then pressing them again as normal. This happens in both single-player and multi-player.
Comment 1 Mike Lightner 2019-01-05 09:31:41 UTC
Accidental double-submission.

*** This bug has been marked as a duplicate of bug 1238 ***