Bug Tracker – Bug 1265

Instant type lower/raise lifts sometimes fail to raise

Last modified: 2019-08-12 21:32:50 CDT
Bug 1265 - Instant type lower/raise lifts sometimes fail to raise
Summary: Instant type lower/raise lifts sometimes fail to raise
Status: RESOLVED FIXED
Alias: None
Product: Odamex
Classification: Unclassified
Component: Server (show other bugs)
Version: 0.8.x
Hardware: All Other
: P5 normal
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks: 1275
  Show dependency tree
 
Reported: 2019-02-09 08:06 CST by Nick
Modified: 2019-08-12 21:32 CDT (History)
3 users (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Nick 2019-02-09 08:06:27 CST
Brit 10 map07 will fail when connected to the server. 

This issue generally happens the very first time you run at the instant lift in the center of the map.

https://www.wad-archive.com/wad/61c269d3daedc65340502493418bd5eb

The problem is that the server will not raise the floor because it thinks its still in motion because it does not remove moving floors every tic.

From SV_StepTics in sv_main.cpp:
		// Since clients are only sent sector updates every 3rd tic, don't destroy
		// the finished moving sectors until we've sent the clients the update
		if (P_AtInterval(3))
			SV_DestroyFinishedMovingSectors();

In testing removing AtInterval if satement will allow the lift to raise as expected but isn't the correct fix.
Comment 1 Nick 2019-02-17 08:46:47 CST
Fixed on my fork:
https://github.com/hobomaster22/odamex/tree/bug/1265
Comment 2 Maëllig Desmottes 2019-06-19 11:14:52 CDT
Has this one been solved ?
Comment 3 HeX_Vulture 2019-08-12 21:32:50 CDT
resolved by author