Bug Tracker – Bug 188

Rendering error when eye is level with the floor

Last modified: 2012-10-15 04:03:55 UTC
Bug 188 - Rendering error when eye is level with the floor
Summary: Rendering error when eye is level with the floor
Status: RESOLVED FIXED
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.0.1
Hardware: All All
: P2 normal
Assignee: Odamex Bug Reporter
URL:
Depends on: 425
Blocks: 523
  Show dependency tree
 
Reported: 2006-04-06 16:16 UTC by Alexander Mayfield
Modified: 2012-10-15 04:03 UTC (History)
3 users (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Mayfield 2006-04-06 16:16:54 UTC
This is due to a bug in the origional doom source where your view height lagged behind your actual position.  When you kill yourself on a fast elevator that is going up, you move so fast and you lag so far that your view height is actually THROUGH the floor.  We need to decide if it's worth fixing or not, since it is this way in the actual doom2.exe as well.  (Eternity and ZDoom 1.22 both exhibit this behavior as well)
Comment 1 Mike Lightner 2006-04-07 13:46:34 UTC
then I see no real reason to fix it.  Mark WONTFIX?
Comment 2 Ralph Vickers 2006-04-09 01:30:53 UTC
But doom2.exe didn't have a client/server netcode. Does this create a different problem to be exhibited in both scenarios?
Comment 3 Denis Lukianov 2006-04-09 08:39:58 UTC
i think the problem is slightly worse due to c/s
Comment 4 Denis Lukianov 2007-01-19 17:46:13 UTC
reassigning to SoM, as he is working on the cardboard renderer
Comment 5 som 2007-01-19 17:51:33 UTC
(In reply to comment #4)
> reassigning to SoM, as he is working on the cardboard renderer
> 

I don't think that cardboard will fix this bug... I'm sure there is a way to fix it though. I'll look at it anyway ;)
Comment 6 Mike Lightner 2009-12-30 17:01:41 UTC
Still valid?
Comment 7 KBlair 2010-01-16 00:54:03 UTC
This bug is still present as of r1429.
Comment 8 Ralph Vickers 2012-10-15 04:03:55 UTC
With Russell and Sean's respective improvements to moving sectors since this bug was filed, this is no longer really a problem. Marking fixed