Bug Tracker – Bug 21

consolidate common code from c/s into common

Last modified: 2008-08-13 01:03:22 UTC
Bug 21 - consolidate common code from c/s into common
Summary: consolidate common code from c/s into common
Status: RESOLVED FIXED
Alias: None
Product: Odamex
Classification: Unclassified
Component: Server & Client (show other bugs)
Version: (old) 0.0.1
Hardware: All All
: P2 normal
Assignee: Denis Lukianov
URL:
: 509 (view as bug list)
Depends on:
Blocks: 404
  Show dependency tree
 
Reported: 2005-10-04 22:28 UTC by Denis Lukianov
Modified: 2008-08-13 01:03 UTC (History)
1 user (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Lukianov 2005-10-04 22:28:58 UTC
Most files should be identical for client and server, and should therefore live
in the common directory. Now comes the problem... there have been changes that
make it difficult to consolidate the files. I've merged the obvious ones
already, but the rest require careful attention to detail and editing. Be
intelligent, don't break anything!
Comment 1 Mike Lightner 2006-02-02 21:40:06 UTC
Bug accepted, awaiting further development.
Comment 2 Mike Lightner 2006-02-06 17:20:22 UTC
Reassigned to Dash.
Comment 3 Mike Lightner 2006-02-07 18:54:25 UTC
Bug accepted.
Comment 4 Denis Lukianov 2006-02-11 01:21:36 UTC
Need to start moving client-only things back out of common, the server does not need all the gfx stuff 
and takes too long to build.
Comment 5 Mike Lightner 2006-02-26 01:42:35 UTC
Status report?
Comment 6 Denis Lukianov 2006-02-26 05:13:52 UTC
as of r969:

need to remove from server:
c_console, ct_chat, v_draw, hu_stuff, v_text, wi_stuff

need to move from common to client:
st_*, r_*, f_*

These are all rather delicate operations with many depends and may take time.
Comment 7 Denis Lukianov 2006-02-26 05:15:30 UTC
also, c_cvars.cpp needs to go from c+s to common
Comment 8 Denis Lukianov 2006-02-26 07:28:48 UTC
r974 moved c_cvars.cpp to common
Comment 9 Denis Lukianov 2006-03-08 11:16:45 UTC
What is left as of r1039:

Move c_console, v_draw, v_video, v_palette, st_* and r_* from server&common to client.

These are the most difficult lot because they work closely with other common code.
Comment 10 Dean Joseph 2006-09-12 23:53:49 UTC
r1451 significantly changes common code, especially for server. Following list of changes:

Moved r_bsp.cpp and r_segs.cpp from /common to /client
Seperated r_draw.*, r_plane.*, r_sky.* and r_things.cpp from /common to /client and /server. r_draw, r_plane and r_sky need to be removed from /server as they contain minimal code (though tricky to remove). r_things.cpp is a lot more sensitive as there's a lot more code than the other files
Removed v_video.cpp and st_stuff.* from /server, moved st_stuff.h to /common
Comment 11 Dean Joseph 2006-09-12 23:56:10 UTC
(In reply to comment #10)
> moved st_stuff.h to /common
> 

That should say "moved st_stuff.h from /client to /common", my bad.
Comment 12 Denis Lukianov 2006-09-28 16:26:14 UTC
r1634: p_enemy.cpp moved into common
Comment 13 Denis Lukianov 2006-09-28 17:03:22 UTC
(In reply to comment #9)
> What is left as of r1039:
> Move c_console, v_draw, v_video, v_palette, st_* and r_* from server&common to
> client.

had a look at c_console.cpp, that probably should not be removed from the server
Comment 14 Mike Lightner 2006-11-06 13:07:56 UTC
r1956 - Moved p_local.h to common (well denis did anyway :P)
Comment 15 Denis Lukianov 2008-05-15 12:58:52 UTC
p_interaction.cpp could use integration into common, as could some duplicated functions. as far as this bug is concerned, it is close enough. marking fixed.
Comment 16 Denis Lukianov 2008-08-13 01:03:22 UTC
*** Bug 509 has been marked as a duplicate of this bug. ***