Bug Tracker – Bug 225

r1685 stress test bugs

Last modified: 2009-12-30 18:55:09 UTC
Bug 225 - r1685 stress test bugs
Summary: r1685 stress test bugs
Status: RESOLVED INVALID
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.0.1
Hardware: x86 (Windows, Linux, etc) Windows (Any)
: P2 minor
Assignee: Denis Lukianov
URL:
Depends on:
Blocks: 424
  Show dependency tree
 
Reported: 2006-10-01 19:35 UTC by Jason Masihdas
Modified: 2009-12-30 18:55 UTC (History)
1 user (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Masihdas 2006-10-01 19:35:45 UTC
1) Chainsaw sound effect pitch continues to play if I fire the chainsaw for more than a couple of seconds. When this happens, it plays at a higher pitch, as if Im hitting another player.

2) If there are other people using chainsaws near me, I cannot hear my own chainsaw.

3) Players would occasionally blink.

4) When scaling for high resolutions is active, hud messages would scale correctly, However, neither the scoreboard nor the hud items (armor count, health, ammo) would scale.

5) I was occasinoally immune to my own rocket damage.

6) Sometimes I couldnt hurt some other players and vice versa.
Comment 1 Denis Lukianov 2006-10-01 19:46:01 UTC
1&2) to joe

3) netcode in progress

4) yeah, this is bug as far as i can tell

5) unsure, maybe because weapon switching was desync'ed?

6) probably because they were ghosts? netcode in progress

Comment 2 Dean Joseph 2006-10-01 21:34:12 UTC
Ralph said these:

<Ralphis> Bug 1) Remote doors open server side but not client side. On rare occasion, client doors open much after it is triggered. Same can happen if closing a door from opposite side.
<Ralphis> 2) Many ghosts appear on playing field
<Ralphis> 3) Teams don't appear in CTF
<Ralphis> 4) Opponent movement is jittery
<Ralphis> 5) Scoreboards b0rk3d
<Ralphis> 6) Player running animations NEVER play. Damage animations play on occasion
<Ralphis> 7) Names are totally screwed
<Ralphis> 8) Exit lines (walkable) have no effect. This can cause maps made in the past few years to play as unintended.
<Ralphis> 9) Coop breaks with 4+ Players (ERROR: szp pointer was NULL)

3 is a duplicate of 208 and 5/7 aren't very specific, but 5 relates to players receiving unnatural statistics such as deaths/time upon connect (bug 205?) and 7 seems to be related to erroneous data being sent on connection of other players
Comment 3 Denis Lukianov 2006-10-01 22:52:16 UTC
R is for Ralphis :)

R1) am aware, blame hexen, see bug 224

R2) I believe these are dead players that didn't do a death anim, will investigate. See R6.

R3) This is a bug.

R4) Netcode in heavy development.

R5) Bug.

R6) Netcode in heavy development.

R7) R5.

R8) We now have several exit options

R9) This is a bug due to new playerid management (we don't have a static player array anymore, so player ids can have gaps!).

Thanks to all of you who participated in the test, and I hope that our next test will be less painful. The gameplay has degraded, in places, because of hexen removals and code restructuring. Most of the structural stuff is now stable for the next lot of gameplay improvements, and I'll be following up these issues closely.
Comment 4 Denis Lukianov 2006-10-01 22:59:39 UTC
Also:

A) wad downloading is either too slow or too jumpy (missed/duped packets)
B) there's a little connection glitch, sometimes takes two tries
C) on map30 the spawnroom has a wall where clipping fails, next to one of the hanging corpses
D) monster updates don't sync often enough, sometimes spawn cubes keep flying clientside past the normal places
Comment 5 Denis Lukianov 2006-10-02 04:52:45 UTC
what I heard from deathz0r:

E) coop spawn 4+ players broke
F) pointer error when killed by unknown actor
Comment 6 Dean Joseph 2006-10-02 16:30:52 UTC
(In reply to comment #4)
> C) on map30 the spawnroom has a wall where clipping fails, next to one of the
> hanging corpses
> 

Fixed in r1712
Comment 7 Denis Lukianov 2006-10-09 09:56:02 UTC
R2 was fixed some time ago
R9 has had some progress
Comment 8 Ralph Vickers 2007-01-23 18:46:32 UTC
Here is a revision of the bugs I posted a few months ago. This is their status as of r86-pub.

R1)Still exists.
R2) Despite being claimed as fixed, still exists. Not only is it just ghost bodies now, sometimes player animations don't goto the last frame of death.
R3) Seems to be fixed
R4) Netcode related. Noted various times. Is presumably related to many other bugs.
R5) Fixed
R6) Fixed
R7) Fixed
R8) Fixed
R9) Untested personally.
Comment 9 Mike Lightner 2009-12-30 18:55:09 UTC
Almost 3 years no info, most things fixed.  Closing.