Bug Tracker – Bug 237

r1800 stress test bugs

Last modified: 2009-12-30 18:52:42 UTC
Bug 237 - r1800 stress test bugs
Summary: r1800 stress test bugs
Status: RESOLVED INVALID
Alias: None
Product: Odamex
Classification: Unclassified
Component: Server & Client (show other bugs)
Version: (old) 0.0.1
Hardware: All All
: P2 normal
Assignee: Denis Lukianov
URL:
Depends on:
Blocks: 424
  Show dependency tree
 
Reported: 2006-10-15 18:14 UTC by Dean Joseph
Modified: 2009-12-30 18:52 UTC (History)
1 user (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Joseph 2006-10-15 18:14:53 UTC
I'm shocked that nobody decided to report this when we did this days ago, so here goes:

"<deathz0r> so flag capturing = broken"
Flag capturing appears to give a team score dependant on how many players are on the capturing team

"<deathz0r> teamplay = always on"
Fairly self-explanatory. Even with teamplay set to 0, I couldn't attack Ralph and he couldn't attack me as we were part of team "red", but I could attack RottKing and HumanBones, and they were able to attack each other since RottKing had his team set to "blue" and HumanBones to "none"

"<deathz0r> unknown error involving w_cachelumpnum: -1 >= numlumps
<meatwad> that's what i get
<meatwad> but i wasn't sure if that was always there
<Ralphis> yea i get it a lot"
I only got this once, and I don't entirely understand how it's reproducable.

"<deathz0r> forcing team colours does not work"
Self-explanatory. I never got confirmation from people on the opposite team as myself, but I saw all of them as black and my team members with our normal player colours

"<RottKing> Did anyone else get those "Consistency Error:" bugs?
<Ralphis> yea they're known
<Ralphis> its something left over from zdoom"
Relates to bug 126
Comment 1 Denis Lukianov 2006-10-16 04:39:59 UTC
(In reply to comment #0)
> I'm shocked that nobody decided to report this when we did this days ago, so
welcome to my world :)

> "<deathz0r> so flag capturing = broken"
> Flag capturing appears to give a team score dependant on how many players are
> on the capturing team
Not sure how/why this happens. What revision was this?

> "<deathz0r> teamplay = always on"
> Fairly self-explanatory. Even with teamplay set to 0, I couldn't attack Ralph
> and he couldn't attack me as we were part of team "red", but I could attack
> RottKing and HumanBones, and they were able to attack each other since RottKing
> had his team set to "blue" and HumanBones to "none"
fixed r1811, test please

> "<deathz0r> unknown error involving w_cachelumpnum: -1 >= numlumps
> <meatwad> that's what i get
> <meatwad> but i wasn't sure if that was always there
> <Ralphis> yea i get it a lot"
> I only got this once, and I don't entirely understand how it's reproducable.
something to do with changing skins, then changing back, changing to an invalid skin? please find a way to reproduce.

> "<deathz0r> forcing team colours does not work"
> Self-explanatory. I never got confirmation from people on the opposite team as
> myself, but I saw all of them as black and my team members with our normal
> player colours
it half-works, confirmation anyone?

> "<RottKing> Did anyone else get those "Consistency Error:" bugs?
> <Ralphis> yea they're known
> <Ralphis> its something left over from zdoom"
> Relates to bug 126
this is odd, will look into it
Comment 2 Dean Joseph 2006-10-16 19:12:12 UTC
(In reply to comment #1)
> > "<deathz0r> so flag capturing = broken"
> > Flag capturing appears to give a team score dependant on how many players are
> > on the capturing team
> Not sure how/why this happens. What revision was this?
r1800.
Comment 3 Denis Lukianov 2006-10-18 06:59:40 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > > "<deathz0r> so flag capturing = broken"
> > > Flag capturing appears to give a team score dependant on how many players are
> > > on the capturing team
> > Not sure how/why this happens. What revision was this?
> r1800.
> 
can't reproduce
Comment 4 Denis Lukianov 2006-10-20 11:02:14 UTC
> > "<deathz0r> forcing team colours does not work"
try r1826
Comment 5 Denis Lukianov 2006-10-20 11:19:00 UTC
> > "<RottKing> Did anyone else get those "Consistency Error:" bugs?
> > <Ralphis> yea they're known
> > <Ralphis> its something left over from zdoom"
> > Relates to bug 126
> this is odd, will look into it

removed it in r1827
Comment 6 Alexander Mayfield 2007-09-25 22:13:15 UTC
This is an oooooooold bug, and is a dreaded multipart bug to boot.  Any updates, because if not I would just as soon close it.
Comment 7 Mike Lightner 2009-12-30 18:52:42 UTC
No more bugs like this - individual things have to be reported.