Bug Tracker – Bug 289

Multiple "oof" sounds when hitting a floor

Last modified: 2010-01-03 18:42:57 UTC
Bug 289 - Multiple "oof" sounds when hitting a floor
Summary: Multiple "oof" sounds when hitting a floor
Status: RESOLVED DUPLICATE of bug 135
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.x Alpha
Hardware: All All
: P2 trivial
Assignee: Denis Lukianov
URL:
Depends on:
Blocks: 424
  Show dependency tree
 
Reported: 2007-01-21 07:44 UTC by TheDarkArchon.KDiZD
Modified: 2010-01-03 18:42 UTC (History)
2 users (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description TheDarkArchon.KDiZD 2007-01-21 07:44:45 UTC
When falling from a sufficient height to cause the oof sound to play, the sound will play several times instead of just once
Comment 1 Denis Lukianov 2007-01-21 10:46:13 UTC
another one for the netcode
Comment 2 Nes 2007-01-21 17:17:57 UTC
This happens to other sounds, too. The only ones I can definitely confirm at the moment is Rocket Launcher firing and Rocket explosion.
Comment 3 Matthew Wegner 2007-02-05 14:27:16 UTC
In this particular instance, since the sound is played during the viewhieght "crouch" adjustment it plays every time the viewheight is decremented/incremented after a fall. This can be fixed with a static boolean variable to ensure it is only played once, but this may not be suitable since other sounds seem to play multiple times as well...
Comment 4 Matthew Wegner 2007-02-05 15:04:04 UTC
In addition to my last comment I forgot to mention that unless there is a suitable place to reset a boolean variable the sound won't actually play ever again.
Comment 5 Matthew Wegner 2007-02-06 10:31:09 UTC
Bah, I looked at the bug more, and realised how dumb what I said is.
Comment 6 Mike Lightner 2010-01-03 18:42:57 UTC
Marked as duplicate of bug 135.

*** This bug has been marked as a duplicate of bug 135 ***