Bug Tracker – Bug 304

Weapon Pickup Doesnt Switch

Last modified: 2008-05-04 13:02:24 UTC
Bug 304 - Weapon Pickup Doesnt Switch
Summary: Weapon Pickup Doesnt Switch
Status: RESOLVED DUPLICATE of bug 269
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.0.1
Hardware: x86 (Windows, Linux, etc) Windows (Any)
: P2 minor
Assignee: Denis Lukianov
URL:
Depends on:
Blocks:
 
Reported: 2007-01-24 00:42 UTC by Catoptromancy
Modified: 2008-05-04 13:02 UTC (History)
1 user (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Catoptromancy 2007-01-24 00:42:36 UTC
Similar to #169 part 4, trying to plasma bump while shooting pistol and getting hurt at same time seems to trigger it. Took over 5 minutes to recreate.
Bumped plasma, sprite change to plasma gun but still shot bullets and injured other player with bullets. Once the "plasma" bullets ammo ran out, I tried to use pistol, it was firing but no marks on wall or pain for other player. 
Also no pistol or plasma sound was played while shooting bullets with plasma gun sprite or while shooting pistol with pistol sprite.
Comment 1 Alexander Mayfield 2007-09-25 22:10:51 UTC
Probably a duplicate of bug 269
Comment 2 Denis Lukianov 2008-05-04 13:02:24 UTC
marking dupe

*** This bug has been marked as a duplicate of bug 269 ***