Bug Tracker – Bug 332

wallhack player hiding code hides sound

Last modified: 2016-11-11 20:09:03 UTC
Bug 332 - wallhack player hiding code hides sound
Summary: wallhack player hiding code hides sound
Status: RESOLVED INVALID
Alias: None
Product: Odamex
Classification: Unclassified
Component: Server & Client (show other bugs)
Version: (old) 0.x Alpha
Hardware: All All
: P2 normal
Assignee: Odamex Bug Reporter
URL:
: 468 (view as bug list)
Depends on:
Blocks: 424
  Show dependency tree
 
Reported: 2007-03-31 21:42 UTC by Albert Brown
Modified: 2016-11-11 20:09 UTC (History)
3 users (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Brown 2007-03-31 21:42:21 UTC
You cannot hear a hidden (behind a wall) player fire  a hitscan weapon (pistol, shotgun, ect).  well, weapons where the projectile isnt what makes the sound - according to GhostlyDeath
Comment 1 Dean Joseph 2007-04-01 22:40:19 UTC
How odd, I thought I reported this but I guess I never did. Still, I should point out that this is related a lot with bug 218.
Comment 2 Ralph Vickers 2007-09-08 17:18:41 UTC
After more rigorous testing, we've come this conclusion:

If player B is not in sight of player A, player A can only hear player B fire projectiles (rockets, plasma, BFG).

If player B is not in sight of player A, player A cannot hear Player B fire any hit scan weapons (pistol, shotgun, super shotgun, chaingun). They also cannot hear a chain saw fire OR a chain saw's idling.
Comment 3 Ralph Vickers 2007-09-24 23:24:15 UTC
The same bug, this also prevents player jump sounds (hitting the ground) if hidden. 
Comment 4 GhostlyDeath 2008-05-29 23:13:21 UTC
*** Bug 468 has been marked as a duplicate of this bug. ***
Comment 5 Dr. Sean 2011-04-26 00:53:35 UTC
The bug only applies when SV_ANTIWALLHACK is set to 1.

The antiwallhack setting prevents the server from sending information about players that are not visible from the client's current position.  Since the information about which sound other players are making is included in the information withheld by the server, clients can't hear sounds made by players the server doesn't let the client know about.

Missiles and other projectiles are AActors separate from the player and their information is not withheld ever by the server: hence they're audible and hitscan attacks or grunts are not.

One solution would be to spawn an invisible AActor for each sound a player makes instead of having the player emit sound.  This sound actor would follow the player and be destroyed when the sound is done or when the player needs to make another sound (eg, Silent BFG).
Comment 6 Ralph Vickers 2016-11-11 20:09:03 UTC
We removed support for the anti-wallhack a couple of versions ago because it didn't work very well. This bug was one of the reasons for removal because there is not a very good solution and it just didn't work. Marking invalid simply because there's nothing left to fix here.