Bug Tracker – Bug 418

Flag gets in HUD sometimes while running

Last modified: 2008-05-23 15:35:55 UTC
Bug 418 - Flag gets in HUD sometimes while running
Summary: Flag gets in HUD sometimes while running
Status: RESOLVED FIXED
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.x Alpha
Hardware: All All
: P2 normal
Assignee: Denis Lukianov
URL:
Depends on:
Blocks: 424 441
  Show dependency tree
 
Reported: 2008-04-17 20:31 UTC by metroidcrazy
Modified: 2008-05-23 15:35 UTC (History)
0 users

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description metroidcrazy 2008-04-17 20:31:20 UTC
Well, if you grab a flag and start to run you see it blink in your HUD quite a few times. It's quite annoying.

R581 used, also Windows XP and Intel Build. (But others have seen it too)
Comment 1 Denis Lukianov 2008-05-12 18:04:05 UTC
i have fixed this before, and it is now broken again. this is because no regression test was added to test this.
Comment 2 Denis Lukianov 2008-05-18 14:20:18 UTC
this looks like a slightly different bug though. only happens after scorelimit is hit, not in the first game.
Comment 3 Denis Lukianov 2008-05-23 15:22:50 UTC
for this to happen, deathmatch must be 1

can reproduce on r816
Comment 4 Denis Lukianov 2008-05-23 15:35:55 UTC
fixed r817