Bug Tracker – Bug 445

Player death sound after certain join/spectate switch

Last modified: 2011-06-16 17:03:01 UTC
Bug 445 - Player death sound after certain join/spectate switch
Summary: Player death sound after certain join/spectate switch
Status: RESOLVED FIXED
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.x Alpha
Hardware: All All
: P2 minor
Assignee: Denis Lukianov
URL:
Depends on:
Blocks: 424 620
  Show dependency tree
 
Reported: 2008-05-18 22:47 UTC by Brandon Del Bel
Modified: 2011-06-16 17:03 UTC (History)
3 users (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Brandon Del Bel 2008-05-18 22:47:01 UTC
Connect to a server and open the console

Type join
Type spectate
Type join;spectate

If this bug isn't specific to my build, you should hear the player death sound. I can only reproduce it by using a combined "join;spectate" after joining and spectating at separate times. Typing "join;spectate" again won't reproduce it. Neither will doing it upon first connecting to a server or joining then typing "spectate;join;spectate".
Comment 1 Denis Lukianov 2008-05-22 12:56:14 UTC
netcode. dependency of bug 424
Comment 2 Denis Lukianov 2008-05-23 19:56:26 UTC
reassigning to GhostlyDeath for investigation
Comment 3 GhostlyDeath 2008-05-24 17:56:46 UTC
confirmed
Comment 4 GhostlyDeath 2009-05-15 10:33:43 UTC
Reassigned to Denis
Comment 5 Ralph Vickers 2010-01-15 04:58:37 UTC
Bug still exists as of r1429
Comment 6 Mike Lightner 2011-02-03 13:21:40 UTC
*** Bug 690 has been marked as a duplicate of this bug. ***
Comment 7 Mike Wood 2011-06-16 03:50:47 UTC
I have confirmed the issue and that r2243 resolves it.
Comment 8 Mike Lightner 2011-06-16 17:03:01 UTC
Marking fixed.  It will be available in the forthcoming 0.5.3 release.