Bug Tracker – Bug 489

Resolutions of 320x200 and 640x400 are not displayed on some systems

Last modified: 2009-12-30 17:41:35 CST
Bug 489 - (ARRAY(0x4f39840)) Resolutions of 320x200 and 640x400 are not displayed on some systems
(ARRAY(0x4f39840))
Resolutions of 320x200 and 640x400 are not displayed on some systems
Status: RESOLVED FIXED
Product: Odamex
Classification: Unclassified
Component: Client
(old) 0.4
x86 (Windows, Linux, etc) Windows (Any)
: P2 normal
Depends on:
Blocks: ARRAY(0x51ef838)
  Show dependency tree
 
Reported: 2008-06-22 18:36:39 CDT by myk
Modified: 2009-12-30 17:41 CST (History)
4 users (show)

See Also:


Attachments
proposed patch (2.08 KB, patch)
2009-12-29 10:00:55 CST, Brandon Del Bel
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description myk 2008-06-22 18:36:39 CDT
I checked Bug 301 "Video mode menu doesn't show all resolutions with some video configurations", but mine seems to be a different issue.

These "classic" 4:3 modes do not show up in the menu, and I can't set them through the console either; they are just ignored, and Odamex uses 640x480 instead.

I've had a similar issue with Chocolate Doom, and an option was added to it in chocolate-doom.cfg to address the problem: autoadjust_video_settings. If I am not mistaken, setting it to 0 tells the engine to ignore whether the video drivers say these resolutions are available and use them anyway. This solves the problem for me. My (Windows 98) system uses some 32 MB SiS model video card, if that matters.
Comment 1 Russell Rice 2008-06-22 19:35:59 CDT
Can you run this: ﷒0﷓ and paste the contents of stdout.txt here?

By default, odamex uses GDI instead of directx, you can try running with the -directx parameter to see if the list changes.
Comment 2 myk 2008-06-26 16:04:34 CDT
1280 x 1024
1280 x 720
1024 x 768
1024 x 576
800 x 600
800 x 480
640 x 480

In Chocolate Doom I need both DirectX (I generally apply the environment variable there) and autoadjust_video_settings 0 to get things going properly at 320x200.
Comment 3 myk 2008-06-26 16:13:38 CDT
Ah, I forgot to confirm that -directx doesn't add the missing modes.
Comment 4 Brandon Del Bel 2008-07-12 22:17:16 CDT
My menu doesn't show 320x200, but I can set it in the cfg.
Comment 5 Brandon Del Bel 2008-07-12 22:18:43 CDT
I forgot to mention that this is on linux.
Comment 6 Mike Wood 2009-12-28 22:14:31 CST
(In reply to comment #5)
> I forgot to mention that this is on linux.

The menu should show whatever resolutions are reported by SDL. These should include all resolutions recognized by xrandr. Add these resolutions your "Modes" line for your default depth (should be 24) within your screen section of xorg.conf. Then restart X and the resolutions should be there.
Comment 7 Brandon Del Bel 2009-12-29 10:00:55 CST
Created ﷒0﷓
proposed patch

This patch adds an autoadjust_video_settings cvar like chocolate doom.
Comment 8 myk 2009-12-29 14:32:21 CST
I have tested a binary Brandon complied with the above patch and it indeed allows resolutions like 320x200 and 640x400 to be set manually (since they are not on the menu) when autoadjust_video_settings is set to 0.

Thanks Brandon!
Comment 9 Mike Lightner 2009-12-30 16:53:53 CST
Patch applied in revision 1360.  As this has already been tested, we'll mark this bug "fixed" for now.  I think it's worth noting that in the future the video mode selection system will hopefully be much improved.
Comment 10 Brandon Del Bel 2009-12-30 17:39:44 CST
I can't reproduce with 0.4.4
Comment 11 Brandon Del Bel 2009-12-30 17:41:35 CST
(In reply to comment #10)
> I can't reproduce with 0.4.4

oops, wrong bug