Bug Tracker – Bug 490

master server redundancy/improvements

Last modified: 2008-07-27 12:51:24 UTC
Bug 490 - master server redundancy/improvements
Summary: master server redundancy/improvements
Status: RESOLVED DUPLICATE of bug 254
Alias: None
Product: Odamex
Classification: Unclassified
Component: Master (show other bugs)
Version: (old) 0.4
Hardware: All All
: P2 major
Assignee: Denis Lukianov
URL:
Depends on:
Blocks:
 
Reported: 2008-07-02 18:45 UTC by Russell Rice
Modified: 2008-07-27 12:51 UTC (History)
2 users (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Russell Rice 2008-07-02 18:45:02 UTC
I always thought the masters contacted eachother to keep a fresh list of servers just in case one goes down.

This is not the case as Manc pointed out and if we are going to have multiple masters running, we should do this.

So, masters should contact eachother, but only if they are on an "official" list of addresses, a whitelist.
Comment 1 GhostlyDeath 2008-07-16 19:00:14 UTC
Also, make the max number of servers optional, maybe a master server host wants more than 1024? there's also max server per IP, maybe this can be made changeable also and possibly allow exceptions to the rule.
Comment 2 Denis Lukianov 2008-07-18 15:31:59 UTC
this is a dupe of bug 254

if masters contact each other, the following will happen:
a) complexity of code will become unmanageable
b) redundancy is reduced as a faulty/stuck/attacked list on one will propagate to the other

i am very concerned about both, and think our current master works quite well already

if we want to see all entries, maybe this is better off being done as a merge of received lists on the launcher?

Comment 3 Russell Rice 2008-07-20 07:41:41 UTC
Okay then

> 
> if we want to see all entries, maybe this is better off being done as a merge
> of received lists on the launcher?
> 

This is done already
Comment 4 Mike Lightner 2008-07-27 12:51:24 UTC
Can't believe we didn't notice this before, duplicate of 254.

*** This bug has been marked as a duplicate of bug 254 ***