Bug Tracker – Bug 509

Redundant and Repeated Code

Last modified: 2008-08-13 16:33:21 UTC
Bug 509 - Redundant and Repeated Code
Summary: Redundant and Repeated Code
Status: RESOLVED DUPLICATE of bug 21
Alias: None
Product: Odamex
Classification: Unclassified
Component: Server & Client (show other bugs)
Version: (old) 0.4
Hardware: All All
: P2 normal
Assignee: Denis Lukianov
URL:
Depends on:
Blocks: 404
  Show dependency tree
 
Reported: 2008-08-12 23:57 UTC by GhostlyDeath
Modified: 2008-08-13 16:33 UTC (History)
0 users

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description GhostlyDeath 2008-08-12 23:57:34 UTC
There is alot of code between the client and the server that is shared, if someone forgets to change something in the client then the server will be messed up and vice versa. Alot of functions are identical, shared or common code should be placed in common/ and remain there unless it is split off again.
Comment 1 Denis Lukianov 2008-08-13 01:03:22 UTC
this bug is vague and does not specify any concrete action to be taken

my guess is that the subjects are p_interaction and p_mobj

marking as duplicate of bug 21, this wil resolve itself with time as nobody likes changing things twice


*** This bug has been marked as a duplicate of bug 21 ***
Comment 2 Denis Lukianov 2008-08-13 16:33:21 UTC
see also bug 404