Bug Tracker – Bug 561

Some desync problems

Last modified: 2010-01-15 07:54:50 UTC
Bug 561 - Some desync problems
Summary: Some desync problems
Status: RESOLVED DUPLICATE of bug 269
Alias: None
Product: Odamex
Classification: Unclassified
Component: Server & Client (show other bugs)
Version: (old) 0.4
Hardware: x86 (Windows, Linux, etc) Windows (Any)
: P2 minor
Assignee: Russell Rice
URL:
Depends on:
Blocks:
 
Reported: 2010-01-10 05:19 UTC by Dmitry Dementjev
Modified: 2010-01-15 07:54 UTC (History)
1 user (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Dementjev 2010-01-10 05:19:13 UTC
Okay, after resolving bug 399 i dl'ded odamex again and tried multiplayer.
And have found in first munute of play some desync bug:
I go and pick up a chaingun, my weapon autoswitches to chaingun, i shoot the wall and see a SSG big bullet spray (meaning that i didn't actually pick CG up).
I then go and pick chaingun again, and this time i get it for real and can shoot it.
Guess it may be an issue with packetloss, as i have some ATM.
Comment 1 Ralph Vickers 2010-01-15 07:54:50 UTC
Detailed this more in bug 269, so I will mark this a duplicate for discussion to be carried on there.

*** This bug has been marked as a duplicate of bug 269 ***