Bug Tracker – Bug 573

Remote Server Administration

Last modified: 2016-11-11 19:57:47 UTC
Bug 573 - Remote Server Administration
Summary: Remote Server Administration
Status: RESOLVED DUPLICATE of bug 221
Alias: None
Product: Odamex
Classification: Unclassified
Component: Server (show other bugs)
Version: (old) 0.5.0 - 0.5.5
Hardware: All All
: P2 enhancement
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks:
 
Reported: 2010-02-25 23:00 UTC by Kyle
Modified: 2016-11-11 19:57 UTC (History)
1 user (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle 2010-02-25 23:00:07 UTC
Apart from the built-in rcon, I've been looking for other ways to remotely administer the server, so far the closest I've gotten is the following script:

mknod odasrv.io p
odasrv -background 1 < odasrv.io
echo "wakey wakey" > odasrv.io

then any commands directed at the FIFO will be issued as commands server side, a netcat server can also be set up to allow this to be remote.

There are two caveats with this method, the first being that it has no method of authentication, the other being that netcat closes as soon as its supply of input is cut off (i.e. as soon as the other connection is canceled).

Proposal:

Upon launch, odasrv listens to port 23 (or other as specified) for incoming telnet connections. Upon connect to this port, it prompts for the rcon password, if the password checks out, it whitelists the ip until a disconnect command is issued, any further text sent through telnet connection would be interpreted as commands in the server.

Eventually, a simple BBS-style system could be put in place for the telnet connection, allowing a simple but attractive way to remote admin a server without having to run the odamex client.
Comment 1 Ralph Vickers 2016-11-11 19:57:47 UTC
Basically a request for remote RCON, which is discussed in 221. Marking duplicate

*** This bug has been marked as a duplicate of bug 221 ***