Bug Tracker – Bug 605

Weapon Desyncs

Last modified: 2010-08-06 05:16:05 UTC
Bug 605 - Weapon Desyncs
Summary: Weapon Desyncs
Status: RESOLVED DUPLICATE of bug 269
Alias: None
Product: Odamex
Classification: Unclassified
Component: Server & Client (show other bugs)
Version: (old) 0.5.0 - 0.5.5
Hardware: All All
: P2 major
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks:
 
Reported: 2010-08-06 05:04 UTC by Kyle
Modified: 2010-08-06 05:16 UTC (History)
1 user (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle 2010-08-06 05:04:02 UTC
Join up to a high ping server (120 and up seems to work) running SVN and 32in24-5 MAP02 (just one of those reproducable maps, its not exclusive to it). Join and run past the BFG and in most cases, the server will never tell the client that it got picked up, thus giving the player an SSG or Pistol that fires BFG shots and uses both cells that the player isn't aware of, as well as using up Pistol or SSG ammo.

This was [re]introduced whenever GhostlyDeath's item pickup code was removed, around revision 1500, if I recall correctly.
Comment 1 Ralph Vickers 2010-08-06 05:09:46 UTC
I just want to go on record to say that this WAS NOT reintroduced because of the removal of GhostlyDeath's code. Ghostly's item/weapon pickup code did not solve desync problems, it only masked them (barely) and caused many other issues on top of them. Ghostly's approach to this fix is not the answer.

In the meantime, Spleen and others have kicked around the idea of having all pick ups be entirely controlled server side. This is worth trying out.
Comment 2 Ralph Vickers 2010-08-06 05:16:05 UTC
Dup of 269

*** This bug has been marked as a duplicate of bug 269 ***