Bug Tracker – Bug 632

Weapon Animation Desyncs

Last modified: 2010-09-08 13:13:38 UTC
Bug 632 - Weapon Animation Desyncs
Summary: Weapon Animation Desyncs
Status: RESOLVED DUPLICATE of bug 269
Alias: None
Product: Odamex
Classification: Unclassified
Component: Server & Client (show other bugs)
Version: (old) 0.5.0 - 0.5.5
Hardware: All All
: P2 normal
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks:
 
Reported: 2010-09-08 02:05 UTC by Kyle
Modified: 2010-09-08 13:13 UTC (History)
1 user (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle 2010-09-08 02:05:35 UTC
Weapon animations sometimes desync with their hitscans/projectiles. As in, fire and the hitscans will be (sometimes dramatically) delayed. Please note that ping isn't the cause of this.

To Reproduce:

This seems to happen sometimes when you run over a weapon while in the process of firing another (happens often while spawning?). You pick it up server-side but the client has to wait until the previous firing animation is over until it can switch, causing a desync. Normal weapon behavior can be restored by waiting for both the client and server to return to a "weapon ready" state.
Comment 1 Mike Lightner 2010-09-08 13:13:38 UTC
Duplicate of the now reopened bug 269.

*** This bug has been marked as a duplicate of bug 269 ***