Bug Tracker – Bug 671

Xbox: huffman_server variable in d_player.h freezes Xbox client

Last modified: 2010-11-20 06:57:35 UTC
Bug 671 - Xbox: huffman_server variable in d_player.h freezes Xbox client
Summary: Xbox: huffman_server variable in d_player.h freezes Xbox client
Status: RESOLVED FIXED
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.5.0 - 0.5.5
Hardware: Xbox All
: P2 major
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks: 667
  Show dependency tree
 
Reported: 2010-11-19 02:00 UTC by Mike Wood
Modified: 2010-11-20 06:57 UTC (History)
0 users

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Wood 2010-11-19 02:00:11 UTC
Before a picture can be displayed the Xbox client freezes on a black screen due to the "compressor" instance of huffman_server in d_player.h. The temporary solution, until the cause is determined, is to compile the Xbox client without the variable as it is not necessary for a client to have it. While the problem is being debugged I am excluding the variable from Xbox with "#ifndef _XBOX" in svn so we can move on with other things.
Comment 1 Mike Wood 2010-11-20 06:57:35 UTC
Fixed in r2004 by adjusting the xbe stack size.