Bug Tracker – Bug 694

Random lockups

Last modified: 2012-07-11 06:40:29 UTC
Bug 694 - Random lockups
Summary: Random lockups
Status: RESOLVED WORKSFORME
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.5.0 - 0.5.5
Hardware: Xbox Other
: P2 major
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks: 667
  Show dependency tree
 
Reported: 2011-03-29 22:09 UTC by Joe
Modified: 2012-07-11 06:40 UTC (History)
1 user (show)

See Also:

Attachments

Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description Joe 2011-03-29 22:09:52 UTC
I couldn't find a place to view current bugs filed so I hope this bug hasn't already been filed.

This problem is in regard to 0.5.1. It was not present in 0.5.0 (same machine) or rather, I never experienced it in the previous version.

Basically what happens is anywhere from a few minutes to an hour after I have started online (co-op) play, the emu will freeze, at which point I have to reset the xbox, restart the emu, and the level, from the beginning (due to the fact that I play online, level progress cannot be saved). I have discontinued play because of this issue.
Comment 1 Mike Wood 2011-03-30 03:03:57 UTC
If you wouldn't mind providing a little more information...

1) How consistent is the issue? Does it always crash within an hour or are you able to play long sessions without a freeze sometimes?
2) What servers have you experienced this with?
3) Do you experience the freezes while playing through the same maps in single-player?
4) Does it generally happen on very large maps or does it happen on all sized maps? Are there particular maps that seem to be more likely to trigger it?
5) If you are running the game at 720p have you tried it at 480p (720x480 or 640x480)? Does the resolution make a difference with this crash?

Because this bug can potentially take a good bit of time to duplicate according to your description it will help a lot in debugging it if I can narrow down the conditions under which it occurs. Thanks.
Comment 2 Joe 2011-03-30 04:46:13 UTC
Let me see if I can get/give some more info.

My resolution is set at 640x480. No 720p for my TV. Tried 800x600. Freezes still.
I can't see all of the server name that I was using last because of an overscan issue but what I can see is "uid DooM][0.5.1 STABLE][COOP#". The IP of the server is 188.95.56.9:10623.
As far as maps, I started SCYTHE2 at map 2 or 3 and got fed up with the freezing at map 8 and quit. Same wad doesn't freeze the emu in single player.
Yes, it usually locks within an hour. I think maybe once, I was able to play longer than an hour without starting over.

Today I played SCYTHE2 from first map to map 7 in single player. Didn't freeze, so then I saved progress, and switched to coop. Froze after about 10 minutes. About 5 minutes after another player (internet) joined me.
Comment 3 Mike Lightner 2011-09-30 00:21:05 UTC
Anything on this?  Please try the latest version (0.5.4).
Comment 4 Joe 2011-10-10 19:57:39 UTC
(In reply to comment #3)
> Anything on this?  Please try the latest version (0.5.4).

Will do.
Comment 5 Mike Wood 2012-07-11 06:40:29 UTC
This report is non-specific and it has been a while, and a number of releases, since the freezing was last confirmed. If the issue is reproduced please feel free to comment and we will reopen the case. Thanks.