Bug Tracker – Bug 710

Monsters play multiple wake-up sounds under certain conditions

Last modified: 2012-11-07 03:03:16 UTC
Bug 710 - Monsters play multiple wake-up sounds under certain conditions
Summary: Monsters play multiple wake-up sounds under certain conditions
Status: RESOLVED DUPLICATE of bug 597
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.5.0 - 0.5.5
Hardware: All All
: P2 normal
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks: 620
  Show dependency tree
 
Reported: 2011-06-13 16:14 UTC by HeX_Vulture
Modified: 2012-11-07 03:03 UTC (History)
0 users

See Also:

Attachments

r2423 Monster Wakeup Demo (48.04 KB, application/zip)
2011-08-09 11:52 UTC, HeX_Vulture
Details
Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description HeX_Vulture 2011-06-13 16:14:42 UTC
Sometimes in co-op you will hear monsters seemingly "wake up" over and over again. This is actually believed to be a desync in which the client thinks the monsters have woken up but they have not on the server. This can actually be easily reproduced in e1m1 on UV online. Simply go to the left and stand in the sector with the two lamps, the two zombies will activate up by the green armor, but the two behind the columns will not. If you fire while in that small sector,  you will experience the bug- the monsters wake up over and over but you will see they do not move out of position or fire.
Comment 1 HeX_Vulture 2011-08-09 11:52:11 UTC
Created attachment 306 [details]
r2423 Monster Wakeup Demo

The attached demo is recorded with r2423 and shows off the bug as described in my previous comment. doom.wad required.
Comment 2 Mike Lightner 2012-11-07 03:03:16 UTC
< AlexMax> we didn't encounter it at all last night, and I accidentally loaded an old odasrv beforehand that replicated it pretty easily
< AlexMax> it is still possible, but it's only possible due to packetloss

We're going to mark this down as a duplicate of the larger packet loss bug #597 at this point.

*** This bug has been marked as a duplicate of bug 597 ***