Bug Tracker – Bug 734

TDM scoreboard issue

Last modified: 2011-08-12 07:05:47 CDT
Bug 734 - (ARRAY(0x4acd0b0)) TDM scoreboard issue
(ARRAY(0x4acd0b0))
TDM scoreboard issue
Status: RESOLVED FIXED
Product: Odamex
Classification: Unclassified
Component: Client
(old) 0.5.0 - 0.5.5
All All
: P2 normal
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-07-21 09:25:12 CDT by vain
Modified: 2011-08-12 07:05 CDT (History)
1 user (show)

See Also:


Attachments
Blue team wins with score 4, red team sees score 5 (fraglimit = 5) - assigned to first problem (179.01 KB, image/jpeg)
2011-07-21 09:25:12 CDT, vain
Details
2. problem - some players does not see score (281.60 KB, image/jpeg)
2011-07-21 09:27:28 CDT, vain
Details
Netdemo reproducing part 2 of the bug (227.05 KB, application/octet-stream)
2011-08-07 15:35:27 CDT, Dr. Sean
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vain 2011-07-21 09:25:12 CDT
Created ﷒0﷓
Blue team wins with score 4, red team sees score 5 (fraglimit = 5) - assigned to first problem

There are two problems with team score counting (on scoreboard, fraglimit works).

First one - different team score, when player change team.
Reproduce - always
1. Connect TDM server with two players
2. Join game with both players in same team (blue for example)
3. Change team with one player to red
4. Blue player now sees on scoreboard -1 for blue team and 0 for red team and player in red team sees score -1 for RED team and 0 for blue team.
0. Blue team wins with 4 (if 5 is fraglimit), on red side score looks right

Second problem - in second round scoreboard does not count team score (always show 0, but fraglimit works).
Reproduce - always
1. Just play first round (map)
2. In second round some players (maybe random - not sure now) always see on scoreboard score 0. Sometimes just reconnect will help. Looks like client side problem, cuz scorelimit works.

Tested on stable 0.5.3 client/server.
Comment 1 vain 2011-07-21 09:27:28 CDT
Created ﷒02. problem - some players does not see score

Screenshot for second problem.
Comment 2 Mike Lightner 2011-08-05 00:10:09 CDT
r2413 fixes part 1 of this bug, please verify.
Comment 3 vain 2011-08-06 08:32:42 CDT
Looks good. First problem fixed. Nice work.
Comment 4 Dr. Sean 2011-08-07 15:35:27 CDT
Created ﷒0﷓
Netdemo reproducing part 2 of the bug

This netdemo easily reproduces the problem described in part 2.  After the first round, the scoreboard always shows a score of 0 for both teams.  When recording this demo, the other player did not have this problem.
Comment 5 Dr. Sean 2011-08-08 19:06:29 CDT
r2420 should fix part 2 of the bug.  Please test and verify.
Comment 6 vain 2011-08-12 07:05:47 CDT
Tested and looks fixed. Nice work guys.