Bug Tracker – Bug 774

Spawned in a HOM void in a cooperative scythe 2 server.

Last modified: 2012-04-13 08:28:52 UTC
Bug 774 - Spawned in a HOM void in a cooperative scythe 2 server.
Summary: Spawned in a HOM void in a cooperative scythe 2 server.
Status: RESOLVED DUPLICATE of bug 475
Alias: None
Product: Odamex
Classification: Unclassified
Component: Client (show other bugs)
Version: (old) 0.5.6
Hardware: x86 (Windows, Linux, etc) Windows (Any)
: P1 critical
Assignee: Odamex Bug Reporter
URL:
Depends on:
Blocks:
 
Reported: 2012-01-21 02:41 UTC by ckassap
Modified: 2012-04-13 08:28 UTC (History)
2 users (show)

See Also:

Attachments

Demo of this happening (3.07 MB, application/x-unknown)
2012-02-01 21:24 UTC, Ralph Vickers
Details
Add an attachment (proposed patch, testcase, etc.)

Note You need to log in before you can comment on or make changes to this bug.
Description ckassap 2012-01-21 02:41:04 UTC
I was on a cooperative server with scythe2.wad as the pwad. When we reached map 28, I spawned in a HOM void. It seemed that I was still in the map, but all walls and barriers were invisible, all I could see were 'things'. The maps before and after worked fine though.
Comment 1 Ralph Vickers 2012-02-01 21:24:10 UTC
Created attachment 332 [details]
Demo of this happening

Here is his demo of this occuring that night. I have not checked it but, having recently experienced a similar phenomenon, I believe this could have occured from the pwad on the server disagreeing with the client pwad. However, the client is still being allowed to connect.
Comment 2 Dr. Sean 2012-02-02 15:12:04 UTC
Would it be possible to have the original poster upload his version of scythe2.wad somewhere so that it can be compared to the server's version of scythe2.wad?  That should at least let us know if pwad mismatch is to blame or if there is a more serious bug present.
Comment 3 Dr. Sean 2012-02-02 15:14:32 UTC
As an aside, I found the following comment in the scythe2.wad documentation:

"This is the sequel to my old megawad "Scythe". Expect better looking and bigger levels. unfortunately, the last 3 levels are missing, because I am so lazy and I haven't been satisfied with my attempts at making map28. I _might_ release the last 3 maps some time in the future, but do not count on it. (Update: the last 3 maps are now completed!)"

The last two sentences lead me to believe there are multiple versions of scythe2.wad floating around, specifically differing in map28.
Comment 4 Ralph Vickers 2012-04-13 08:28:52 UTC
After taking some time to look further into this, I'm going to mark this as a duplicate of Bug 475. The reason I'm doing this is because it seems as though this was caused by a different version of the pwad as Sean mentioned in comment 3.

*** This bug has been marked as a duplicate of bug 475 ***