Bug Tracker – Bug 794

Client left on overnight becomes unresponsive when connected to servers.

Last modified: 2016-09-07 16:16:29 CDT
Bug 794 - (ARRAY(0x5c3e908)) Client left on overnight becomes unresponsive when connected to servers.
(ARRAY(0x5c3e908))
Client left on overnight becomes unresponsive when connected to servers.
Status: NEW
Product: Odamex
Classification: Unclassified
Component: Client
(old) 0.6-dev
All All
: P1 minor
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2012-03-10 00:21:30 CST by Alexander Mayfield
Modified: 2016-09-07 16:16 CDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Mayfield 2012-03-10 00:21:30 CST
A headless client left on overnight connected to a server will become _extremely_ unresponsive while connected to servers, to the point where commands given to the client take forever.  From what I've been able to ascertain, the call to TryStepTics() on line 157 of d_net.cpp ends up being passed some ridiculous number of tics numbering in the thousands to tens-of-thousands, courtesy of the contents of the realtics variable on line 136.

- This happens in SVN r2785.  No clue if it happens in 0.5.6 yet.
- This happens on a headless client.  No clue if it happens in a client without -novid yet.
- Messages from the server seem to be retrieved just fine.  If you 'say hello' on the server, the client undergoing this bug sees it immediately.
- This only happens if you are connected to a server.  If you are kicked or are otherwise forcibly disconnected, realtics values seem to return to normal and any queued commands you tried to use while under the bug's spell are added immediately thereafter.
- If the client is timed out from the server (i.e. being in gdb too long), you're still stuck under the effects of the bug.  You have to wait for TryStepTics to run out.
- Once you reconnect to a server, the bug reappears almost immediately.  The only way to squash it for good is to restart the client.
- This is not a server issue.  If I start a fresh client and connect to the same server as the bugged client, the fresh client works fine.
Comment 1 Mike Lightner 2014-04-04 03:34:12 CDT
Is this still a problem?
Comment 2 HeX_Vulture 2016-09-07 16:16:29 CDT
I have left my client on overnight in inactive co-op servers and went back in the morning and it worked just fine.

It might be worth testing in a server that was previously populated though