Message Boards

Topic: Linux client exits, returns nothing  (Read 4106 times)

Offline quads

  • Posts: 7
    • View Profile
Linux client exits, returns nothing
« on: March 04, 2012, 10:10:19 »
Odalaunch and odasrv both work, but when I try to run the odamex client it flashes up for a split second and exits.  All it returns on the command line is 'Aborted'  Any help?

Offline Hekksy

  • Doomin' since '96
  • Administrator
  • Posts: 152
    • View Profile
Re: Linux client exits, returns nothing
« Reply #1 on: March 04, 2012, 11:54:56 »
Try doing ./odamex -nomusic. Does it start?
Join the Odamex Steam group! http://steamcommunity.com/groups/odamex
Check out the Odamex Discord as well: https://discord.gg/vHUu236

Offline quads

  • Posts: 7
    • View Profile
Re: Linux client exits, returns nothing
« Reply #2 on: March 04, 2012, 12:15:01 »
Arg, I fail.

I saw this during my searching and I thought the midi issue was only on Windows Vista/7.  At any rate, it is now working.  Thanks.

Offline Hekksy

  • Doomin' since '96
  • Administrator
  • Posts: 152
    • View Profile
Re: Linux client exits, returns nothing
« Reply #3 on: March 04, 2012, 17:15:19 »
The midi issue is not a problem on Linux. I think your problem is that you forgot to install timidity, so it has no music playback device.
Join the Odamex Steam group! http://steamcommunity.com/groups/odamex
Check out the Odamex Discord as well: https://discord.gg/vHUu236

Offline quads

  • Posts: 7
    • View Profile
Re: Linux client exits, returns nothing
« Reply #4 on: March 04, 2012, 19:45:01 »
Hmmm...I think I have timidity installed, I'm not on that machine right now but I'll check it tomorrow.  Thanks.