Message Boards

Topic: Trouble connecting  (Read 5677 times)

Inferdramon

  • Nobody
Trouble connecting
« on: November 20, 2010, 18:49:45 »
I recently got Odamex installed on this machine and I have tried connecting to a server. However I am unable to. Every time I try, I get an error message.

http://i165.photobucket.com/albums/u72/Inferdramon/Doomdoesnotwork.png

I have allowed the program to go through my antivirus and firewall and it still does not work. I was suggested to toggle port, but I do not have access to my router from this computer as it is installed on my brother's computer. So I am unable to toggle port.

Is there anything else I can do to get Odamex to work for me?

Offline Ralphis

  • Administrator
  • Posts: 111
    • View Profile
Re: Trouble connecting
« Reply #1 on: November 22, 2010, 17:01:18 »
This looks more like a permissions error rather than anything related to connection settings. Does the administrator account have any programs blocked for your account or do they need to allow new programs to be run?

Inferdramon

  • Nobody
Re: Trouble connecting
« Reply #2 on: November 22, 2010, 18:21:33 »
Well we did manage to get Doom working. What I did was, instead of closing out of Comodo like I had before, I kept it on and just switched to Game Mode. Then my friend did some things on his end.

"Used Odamex with the Doom IWADS.

FIRST, very important!  You must login to your router (I use a Netgear WNR1000v2-VC router), and under the Advanced section on the menu to the left, click Port Forwarding/Port Triggering.

Select the Port Triggering option, NOT the Port Forwarding option, since Port Triggering is more secure, and will close down any vulnerable ports when the services stop running.  Do NOT check the box to disable Port Triggering.  Under Port Triggering Portmap Table, click Add Service.

Set the options accordingly:
Service Name: *anything you want here* I chose the name od1 because of Odamex, and to keep it inconspicuous.
Service User: *Any or Single address* I chose Any so I wouldn't have to enter a specific IP address to toggle this service.
Service Type: *TCP or UDP* I chose UDP since that is the protocol that Odamex uses to connect with.
Triggering Port: *1-65535* I chose 10666 because that is the default port (or seems to be) that Odamex servers connect with.
Inbound Connections:
Connection Type: *TCP/UDP, TCP or UDP* I chose TCP/UDP so whoever connected to this service could use either the TCP protocol or the UDP protocol.
Starting Port: *1-65535* Again, here I chose 10666, because of Odamex using that port number for its servers.  (Is this changeable, I wonder?  Hmm. *random speculation; irrelevant*)
Ending Port: *1-65535* Here, I chose 15000 for the ending port number because port 15000 is the port number that my server used to contact the Master server list and let it know that it was online.
Now, click Apply, and the service should be checked under the Port Triggering Portmap Table.
Click the bottom Apply button after going back to the Port Triggering Portmap Table, and make sure that the Enable checkbox is enabled for the Server/Service.Now, Logout of the router, and close the browser.

Now, the tricky part.  You must have already copied your .wad files to the Odamex folder and also configured the Odamex Launcher to look in that same folder for .wad files (by default it already does this).  Open the odasrv.cfg file, and edit the following:

set sv_hostname: Change the name to whatever name you would like your server to be displayed as. (I changed mine to Neptune's Server.)
set sv_motd: Change the message of the day to whatever you want. (I changed mine to Welcome to my server.)
set sv_usemasters: Make sure this is set to 1, not 0, so your server will show up on the Master server list(s).
set sv_maxclients: I set mine to 2, for the maximum amount of clients that can even connect to my server at all (I include myself as one of them of course, but that's described later).
set sv_maxplayers: I again set this to 2, for the maximum amount of players who can play a game.  If one wanted spectators as well, one would have to set the previous line to a higher number - if this is not done, no more than the specified number can even connect at all.
set join_password: Without setting this to something, anyone can jump on your server, and that wouldn't be very good, now would it?  I set my password to DOOMGaming.
set sv_natport: I DID NOT CHANGE THIS OPTION FROM 0, but I am documenting it here just in case it may need attention later.  This is disabled when it's set to 0, but may be helpful if one has problems getting the server to advertise on the Master server list.  Again, I DID NOT change this - I left it at 0.
set sv_gametype: Choose whatever you want here, for the gametype.  I left it at the defaut of 0, which would have enabled Co-operative play.  It's irrelevant as far as getting the server up and running is concerned, however.
set sv_teamdamage: DOES NOT EXIST YET, but kept here for reference.  This should be set to 0 unless you like to be mean to your teammates... :P
set sv_teamsinplay: I did have this set to 2, but because of the above probem with teamdamage, I should probably have it set to 1, and see if I can turn off Friendly Fire.
set sv_teamspawns: Set to 1 by default - I did NOT change this, but am noting it here for reference.
set sv_skill: I had this set to 3, and it was indeed at 3 by default.  Change it to whatever.
set sv_allowtargetnames: Seems to have been set to 0 by default, despite saying otherwise - I did not turn it on, as there was no need for it. :P
set sv_globalspectatorchat: I believe this was set to 1 by default, and if so, I did not change it from 1. :P
set sv_weaponstay: Keep this set at 1, unless you want to be an unfair pig. xD
set sv_itemsrespawn: I left this at 0.
set sv_nomonsters: Fortunately this was set to 0, and I kept it that way.
set sv_monstersrespawn: Keep this set at 0, unless you're nuts. xD
set sv_fastmonsters: Again, keep it at 0.  There's enough trouble with the teamdamage variable not existing yet. xD
set sv_allowexit: Keep this set at 1, unless you're playing Deathmatch (which I hate to play xP). :P
set sv_allowjump: This was mistakenly set to 0, and affected our game - will set to 1 next time. :P
set sv_freelook: Again, this was mistakenly set to 0, and gave me problems with mouselook - will again set to 1. :P
set sv_friendlyfire: This was set to 1 by mistake; will set to 0 and set teams to 1 so we don't take damage.
set sv_infiniteammo: Keep this set at 0 unless you're a greedy bastard. xD
set sv_fragexitswitch: This was set at 0, but should probably be set to 1 in case we ever decide to do Deathmatch - makes it more interesting. :P
set sv_emptyreset: This was set to 0, I set it to 1 to keep the levels from being lame when all people exit if the server is still up.
set sv_fraglimit: I did not change this from 0, but should we ever Deathmatch, I may change it.
set sv_scorelimit: This is for Capture the Flag - I didn't change this from 5.
set sv_loopepisode: I made sure this was set to 0, in case we ever play Ultimate Doom in co-op mode.
set sv_maxcorpses: I did not change this from 200.
set sv_waddownload: I left this at 0 to disable automatic PWAD downloading.

Finally, save the changes to the file, close the editor, and open the Odamex Server.  (Make sure that any firewalls allow odalaunch.exe, odamex.exe, and odasrv.exe.)  After confirming that the ports being used locally and for broadcasting to the Master server list are the same as those you set in the router configuration, reopen the Odamex Launcher, and just in case, hit the Refresh all servers button.  Now, confirm that your server is on the list, IP address, name, game WAD, game type, and all.  (You can check your WAN IP address at http://www.ipchicken.com)  Also confirm with your partner that they can refresh the server list in their Odamex Launcher and see your server as well.  Give them the password, and let THEM connect first, just in case.  Then, after you have confirmed that they have successfully connected, both in the Odamex Server window and the Odamex Launcher, connect to your own server (do NOT pick the client-only option, or you will be shunted into a single player-only game, and will be stuck wondering what happened), and play!"

Not sure if it was a problem on his end all along or still a problem on my end. Either way we did manage to get Doom working and played a co-op together.

Offline Ralphis

  • Administrator
  • Posts: 111
    • View Profile
Re: Trouble connecting
« Reply #3 on: November 22, 2010, 20:52:27 »
Awesome, great to hear you guys got it up and running!