Message Boards

Topic: Compiling Help  (Read 17471 times)

Offline Qwerty_

  • Posts: 11
    • View Profile
    • The1Qwerty
Re: Compiling Help
« Reply #15 on: November 14, 2007, 00:59:31 »
Well I thought I would take a fresh start at compiling it with v0.3 and it worked. I am using the freedoom IWAD.

However it freezes for me after about 5 seconds of starting up. Is this related to the IWAD I am using or did something go wrong with my compile?

(Also I have made a .deb that I am going to test on my bros PC, not sure if the developers would like it or not, I wanna get everything working though before I post it here. That is assuming the developers want it if not thats cool was an experiment more than anything.)

Offline Memfis

  • Posts: 7
    • View Profile
Re: Compiling Help
« Reply #16 on: November 14, 2007, 07:34:30 »
Can you hear music?sound?
Does it works with -nosound or -nomusic?
(I resolved this problem when returned to standard debian kernel)

Offline Qwerty_

  • Posts: 11
    • View Profile
    • The1Qwerty
Re: Compiling Help
« Reply #17 on: November 14, 2007, 07:52:16 »
I dont get any sound once it locks up. I do get sound initially though.

EDIT:

Ok it turned out I was running SDL_mixer 1.2.6 so I compiled SDL_mixer 1.2.8 then went ahead and recompiled odamex 0.3.

This still resulted in me having the same freezing problem.

After chatting with Russel on the IRC (thanks very much for your help Russel). He suggested that I try out prboom to see if other SDL applications ran.

Prboom required SDL_net to be compiled. I installed SDL_net from the Ubuntu repos, compiled prboom and it ran fine.

After that I thought I would try odamex again, and it worked... even though it does not need SDL_net.

I think ill reboot just incase running prboom first ticked something to start it all working.
« Last Edit: November 16, 2007, 03:02:28 by Qwerty_ »